Выводим в прайс-лист остатки по сериям (УТ11, КА2, ERP2)

Типовой функционал не позволяет выводить в прайс-лист остатки по сериям. Но если такая необходимость возникла — Вы можете воспользоваться нашим расширением Конструктор прайс-листов (прайс-заказов) для УТ11, КА2, ERP2, УНФ, Розница.

Наш конструктор прайс-листов позволяет выводить в прайс-листы различную информацию с описанием номенклатуры, ее цены и остатки. Но вывод остатков по сериям это нестандартная возможность — поэтому мы будем использовать произвольный алгоритм для получения этих остатков. Для этого мы добавляем новую колонку и выбираем в доступных значениях Алгоритм:

Текст алгоритма с получением остатков приведен ниже:

[Алгоритм:
Если Номенклатура.ВидНоменклатуры.ИспользоватьСерии Тогда
Запрос = Новый Запрос(
"ВЫБРАТЬ РАЗРЕШЕННЫЕ
|	ТоварыНаСкладах.Номенклатура КАК Номенклатура,
|	ТоварыНаСкладах.Характеристика КАК Характеристика,
|	ТоварыНаСкладах.Серия КАК Серия,
|	ТоварыНаСкладах.ВНаличииОстаток КАК Остаток
|ИЗ
|	РегистрНакопления.ТоварыНаСкладах.Остатки(
|			,
|			Номенклатура = &Номенклатура
|				И Серия <> ЗНАЧЕНИЕ(Справочник.СерииНоменклатуры.ПустаяСсылка)
|				И Характеристика = &Характеристика
|				И Склад.Наименование = ""Центральный склад"") КАК ТоварыНаСкладах");
Запрос.УстановитьПараметр("Номенклатура", Номенклатура);
Запрос.УстановитьПараметр("Характеристика", ?(ЗначениеЗаполнено(Характеристика), Характеристика, Справочники.ХарактеристикиНоменклатуры.ПустаяСсылка()));
Выборка = Запрос.Выполнить().Выбрать();
Результат = "";
Пока Выборка.Следующий() Цикл
	Если ЗначениеЗаполнено(Результат) Тогда
		Результат = Результат + Символы.ПС + "" + Выборка.Серия + ": " + Выборка.Остаток + " " + Номенклатура.ЕдиницаИзмерения;
	Иначе
	    Результат = "" + Выборка.Серия + ": " + Выборка.Остаток + " " + Номенклатура.ЕдиницаИзмерения;
	КонецЕсли;
КонецЦикла;
КонецЕсли;
]

Для каждой номенклатуры если для нее ведется учет по сериям будет выводиться список серий с указанием остатков по каждой серии и единицей измерения. В алгоритме установлен отбор по центральному складу — Вы можете изменить наименование склада на нужный Вам склад или убрать этот отбор и остатки будут определяться по всем складам.

Если у Вас остались вопросы по функционалу — Вы можете их задать в чате на этой странице!

Наши разработки:
Учет сертификатов номенклатуры в УНФ (печать реестра сертификатов)

Учет сертификатов номенклатуры в УНФ (печать реестра сертификатов)

Расширение конфигурации добавит возможность вести учет сертификатов номенклатуры в конфигурации "Управление нашей фирмой, редакция 1.6". Вы сможете организовать учет сертификатов ...
Обмен 1С и OZON (УТ11, ERP2, КА2, БП3, УНФ, Розница)

Обмен 1С и OZON (УТ11, ERP2, КА2, БП3, УНФ, Розница)

Расширение конфигурации позволяет выполнять автоматический обмен между 1С и OZON и совместимо с актуальными конфигурациями Управление торговлей 11, ERP Управление ...
Расширенная форма заказа клиента для УТ11, КА2, ERP2

Расширенная форма заказа клиента для УТ11, КА2, ERP2

Расширение конфигурации позволяет выводить остатки по всем необходимым складам, отображать цены номенклатуры и дополнительные колонки номенклатуры прямо в списке товаров ...
Управление запасами: Товары поставщиков (УТ11, КА2, ERP2)

Управление запасами: Товары поставщиков (УТ11, КА2, ERP2)

Функционал расширения конфигурации позволяет в удобной форме автоматически загружать прайс-листы поставщиков в 1С, анализировать загруженные данные, автоматически устанавливать цены с ...
Изменение записей регистра сведений (универсальная обработка)

Изменение записей регистра сведений (универсальная обработка)

Обработка дает возможность массово или точечно изменять записи регистра сведений. Поддерживается изменение записей в независимых регистрах и регистрах с подчинением ...
Остатки товаров в РМК (УТ11, КА2, ERP2)

Остатки товаров в РМК (УТ11, КА2, ERP2)

Расширение конфигурации добавит возможность просматривать остатки по складу для выбранных в РМК (рабочее место кассира) товаров. При этом Вы сможете ...

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *